0532 636 58 78

Excel dizi fonksiyonları / Array formülleri

 Microsoft Excel® ile yapılacak en atraksiyonlu işlemler dizi formülü kullanımlarıyla olur. Dizi formülleri çok sayıda formülün iç içe ve kullanımını ve çok sayıda işlemin aynı anda yapılmasını – bir hücreye ya da bir alan verilerin döndürülmesini sağlar.
Diziler ve dizi formülleri hakkında:
Dizi birden çok değeri ifade eder. Örneğin on tane sayı ya da metin veri. Genellikle bir satırdaki veriler ya da sütundaki veriler.
Dizi sabitlerinin gösterimi:
{1;2;3}
{“ali”;”veli”;”ayşe”}
 
Dizi sabitlerinin kullanımı:
=DÜŞEYARA(B3;$H$3:$L$10;{2;3;5};0)
=VLOOKUP(B3;$H$3:$L$10;{2;3;5};0)
 
Yukarıdaki formüller sütun numarası 2, 3, 5 için birer kere çalışacaktır.
 
Dizi formülleri:
Dizi formüllerin özelliği bir ya da daha çok değeri döndürebilmesidir. Tipik olarak birçok koşula uyan verileri sayılması, toplanması ya da öğenin getirilmesidir.
 
=TOPLA((E2:E24)*(D2:D24="NURİ ÖRNEK")*(C2:C24="TATLISAN"))
=SUM((E2:E24)*(D2:D24="NURİ ÖRNEK")*(C2:C24="TATLISAN"))
 
Dizi formülleri = ile yazıldıktan sonra ENTER tuşu yerine CTRL+SHIFT+ENTER tuşlarının birlikte basılmasıyla girilir. Bu girişin ardından formül otomatik olarak büyük parantezler { } içine alınır.
 
{=TOPLA((E2:E24)*(D2:D24="NURİ ÖRNEK")*(C2:C24="TATLISAN"))}
{=SUM((E2:E24)*(D2:D24="NURİ ÖRNEK")*(C2:C24="TATLISAN"))}
 
Aşağıdaki örnekte çok sayıda KAÇINCI fonksiyonu içerisinde koşullarla kullanılarak birçok sütun üzerinde arama yapmayı sağlar.
 
=İNDİS(B2:B24;KAÇINCI(1;(G3=D2:D24)*(G4=C2:C24);0))
İngilizce sürümde:
=INDEX(B2:B24;MATCH(1;(G3=D2:D24)*(G4=C2:C24);0))
 
Bu videoda İNDİS ve KAÇINCI (INDEX ve MATCH) kullanarak bir düşeyarama işlemi yapılmaktadır. Ancak çok sayıda koşul değerlendirilmektedir.
İlgili verinin bulunması (Çok sayıda sütunu aramak)
Çok sayıda sütunun eşleşmesi:
İNDİS içinde KAÇINCI * KAÇINCI * KAÇINCI
INDEX içinde MATCH * MATCH * MATCH
 
Yapısı:
KAÇINCI(1;(kriter1)* (kriter2) * ....   ;0)
MATCH(1;(kriter1)* (kriter2) * ....   ;0)
 
Videolar:
https://www.youtube.com/watch?v=wBGQ1O8blm8&list=PL3dc_-B83C8C4r8Zv1fkMkXK-A9NW4Ruc
 
 
 
 
 
 
 

Diğer Yazılar