0532 636 58 78

İleri-Konu 4.8: TOPLA.ÇARPIM (SUMPRODUCT) Fonksiyonu

 Toplama ve çarpma işlemini birlikte yapan özel bir fonksiyondur. Farklı kullanım amaçlarına uygun çözümler sağlar. Aslında ÇOKETOPLA (SUMIFS) fonksiyonuna çok benzemekle birlikte özellikle içinde fonksiyonlara dayalı ölçütler belirtebildiğimiz için daha güçlü olduğunu belirtebiliriz. 

Dizi (array) kullanımı, ölçütle birlikte kullanım ve ağırlıklı ortalama hesaplamak üzere farklı kullanım şekilleri ve sözdizimleri vardır. 

 
Tipik Kullanımlar
TOPLA.ÇARPIM (SUMPRODUCT) fonksiyonu sütunlardan istenilen verilerin ölçütlere uyanı ve ona uygun olanların toplamını hesaplar. Diğer bir deyişle veri alanlarının kesişimlerini hesaplar.
Örnekler:
=TOPLA.ÇARPIM(A1:C1,A2:C2) ile A1*A2+B1*B2+C1*C2 hücrelerinin çarpımı ve toplamı sağlanır. 

Diğer Yazılar